profile_pic

Brixly

Improved

Feature Request

Announcement

We are excited to announce that, as part of our ongoing commitment to provide our clients with the best possible hosting environment, we have upgraded the default PHP version for all newly created accounts from PHP 7.4 to PHP 8.1. This update ensures that our customers benefit from the latest improvements in performance, security, and features available in PHP.

Key Benefits of PHP 8.1 over PHP 7.4:

  1. Performance Enhancements: PHP 8.1 offers significant performance improvements over PHP 7.4, allowing your websites to load faster and respond more quickly to user interactions.

  2. Improved Security: PHP 8.1 introduces several security enhancements, providing a more secure environment for your websites and applications.

  3. New Features: PHP 8.1 includes various new features such as enums, readonly properties, fibers for better concurrency, and the new never return type. These additions will help developers write more efficient and cleaner code.

  4. Deprecation Cleanup: PHP 8.1 has deprecated and removed outdated functions and features, encouraging developers to adopt modern coding practices and reduce the risk of potential issues in the future.

PHP Selector in cPanel:

While we strongly recommend taking advantage of the benefits offered by PHP 8.1, we understand that some clients may need to use a different PHP version for specific projects or compatibility reasons. To cater to these requirements, you can still select any PHP version using the PHP Selector in your cPanel account. This tool allows you to easily switch between different PHP versions and manage their respective settings as needed.

We encourage all customers to consider upgrading their existing websites and applications to PHP 8.1 to enjoy its performance, security, and feature enhancements. However, please thoroughly test your websites and applications for compatibility before switching to avoid any potential issues.

Compatibility Notice: Elite Module for WHMCS Limited to PHP 7.4

As you take advantage of the benefits offered by PHP 8.1, please note that our Elite Module for WHMCS is currently only compatible with PHP 7.4. We understand the importance of compatibility, and our team is actively working on updating the module to ensure compatibility with PHP 8.1 in the near future.

In the meantime, if you are using our Elite Module for WHMCS, we recommend you continue using PHP 7.4 for your WHMCS installation.

You can easily select PHP 7.4 for your WHMCS instance using the PHP Selector in your cPanel account. This will ensure that your WHMCS installation continues to function smoothly without any compatibility issues.

We appreciate your understanding and patience while we work on updating the Elite Module for WHMCS to be compatible with PHP 8.1. We will notify you as soon as the updated module is available for use with PHP 8.1, so you can enjoy the full range of benefits provided by the latest PHP version.

March 16th 2023